openSUSE Security Update : perl-DBD-mysql (openSUSE-2018-539) (BACKRONYM)

High Nessus Plugin ID 110214

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for perl-DBD-mysql fixes the following issues :

- CVE-2017-10789: The DBD::mysql module when with mysql_ssl=1 setting enabled, means that SSL is optional (even though this setting's documentation has a \'your communication with the server will be encrypted\' statement), which could lead man-in-the-middle attackers to spoof servers via a cleartext-downgrade attack, a related issue to CVE-2015-3152. (bsc#1047059)

- CVE-2017-10788: The DBD::mysql module through 4.043 for Perl allows remote attackers to cause a denial of service (use-after-free and application crash) or possibly have unspecified other impact by triggering (1) certain error responses from a MySQL server or (2) a loss of a network connection to a MySQL server. The use-after-free defect was introduced by relying on incorrect Oracle mysql_stmt_close documentation and code examples. (bsc#1047095)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected perl-DBD-mysql packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1047059

https://bugzilla.opensuse.org/show_bug.cgi?id=1047095

Plugin Details

Severity: High

ID: 110214

File Name: openSUSE-2018-539.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/05/30

Updated: 2018/05/30

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl-DBD-mysql, p-cpe:/a:novell:opensuse:perl-DBD-mysql-debuginfo, p-cpe:/a:novell:opensuse:perl-DBD-mysql-debugsource, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/05/29

Reference Information

CVE: CVE-2015-3152, CVE-2017-10788, CVE-2017-10789