GLSA-201805-10 : Zsh: Multiple vulnerabilities

critical Nessus Plugin ID 110174

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201805-10 (Zsh: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Zsh. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker could execute arbitrary code, escalate privileges, or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Zsh users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-shells/zsh-5.5'

See Also

https://security.gentoo.org/glsa/201805-10

Plugin Details

Severity: Critical

ID: 110174

File Name: gentoo_GLSA-201805-10.nasl

Version: 1.2

Type: local

Published: 5/29/2018

Updated: 6/7/2018

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:zsh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 5/26/2018

Reference Information

CVE: CVE-2017-18205, CVE-2017-18206, CVE-2018-1071, CVE-2018-1083, CVE-2018-1100, CVE-2018-7548, CVE-2018-7549

GLSA: 201805-10