CVE-2018-1083

HIGH

Description

Zsh before version 5.4.2-test-1 is vulnerable to a buffer overflow in the shell autocomplete functionality. A local unprivileged user can create a specially crafted directory path which leads to code execution in the context of the user who tries to use autocomplete to traverse the before mentioned path. If the user affected is privileged, this leads to privilege escalation.

References

http://www.securityfocus.com/bid/103572

https://access.redhat.com/errata/RHSA-2018:1932

https://access.redhat.com/errata/RHSA-2018:3073

https://bugzilla.redhat.com/show_bug.cgi?id=1557382

https://lists.debian.org/debian-lts-announce/2018/03/msg00038.html

https://security.gentoo.org/glsa/201805-10

https://sourceforge.net/p/zsh/code/ci/259ac472eac291c8c103c7a0d8a4eaf3c2942ed7

https://usn.ubuntu.com/3608-1/

Details

Source: MITRE

Published: 2018-03-28

Updated: 2019-04-22

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 7.2

Vector: AV:L/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 3.9

Severity: HIGH

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH