Debian DSA-4204-1 : imagemagick - security update

Medium Nessus Plugin ID 109925

Synopsis

The remote Debian host is missing a security-related update.

Description

This update fixes several vulnerabilities in imagemagick, a graphical software suite. Various memory handling problems or issues about incomplete input sanitizing would result in denial of service or memory disclosure.

Solution

Upgrade the imagemagick packages.

For the oldstable distribution (jessie), these problems have been fixed in version 8:6.8.9.9-5+deb8u12.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=867748

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869827

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869834

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870012

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870065

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885125

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885340

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886588

https://security-tracker.debian.org/tracker/source-package/imagemagick

https://packages.debian.org/source/jessie/imagemagick

https://www.debian.org/security/2018/dsa-4204

Plugin Details

Severity: Medium

ID: 109925

File Name: debian_DSA-4204.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/05/21

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:imagemagick, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/05/18

Reference Information

CVE: CVE-2017-10995, CVE-2017-11533, CVE-2017-11535, CVE-2017-11639, CVE-2017-13143, CVE-2017-17504, CVE-2017-17879, CVE-2018-5248

DSA: 4204