CVE-2017-11639

MEDIUM

Description

When ImageMagick 7.0.6-1 processes a crafted file in convert, it can lead to a heap-based buffer over-read in the WriteCIPImage() function in coders/cip.c, related to the GetPixelLuma function in MagickCore/pixel-accessor.h.

References

http://www.securityfocus.com/bid/100013

https://github.com/ImageMagick/ImageMagick/issues/588

https://usn.ubuntu.com/3681-1/

https://www.debian.org/security/2017/dsa-4019

https://www.debian.org/security/2018/dsa-4204

Details

Source: MITRE

Published: 2017-07-26

Updated: 2018-06-14

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM