PHP 7.0.x < 7.0.30 Multiple Vulnerabilities

high Nessus Plugin ID 109577
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.30. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PHP version 7.0.30 or later.

See Also

http://www.php.net/ChangeLog-7.php#7.0.30

Plugin Details

Severity: High

ID: 109577

File Name: php_7_0_30.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 5/4/2018

Updated: 11/8/2019

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2018-10549

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/26/2018

Vulnerability Publication Date: 4/26/2018

Reference Information

CVE: CVE-2018-10545, CVE-2018-10546, CVE-2018-10547, CVE-2018-10548, CVE-2018-10549

BID: 104019, 104020, 104022