PHP 5.6.x < 5.6.36 Multiple Vulnerabilities

high Nessus Plugin ID 109576

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.36. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PHP version 5.6.36 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.36

Plugin Details

Severity: High

ID: 109576

File Name: php_5_6_36.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 5/4/2018

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-10549

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/26/2018

Vulnerability Publication Date: 4/26/2018

Reference Information

CVE: CVE-2018-10546, CVE-2018-10547, CVE-2018-10548, CVE-2018-10549

BID: 104019, 104020, 104022