Artifex Ghostscript PostScript Handling Buffer Overflow DoS

Medium Nessus Plugin ID 109405

Synopsis

The remote Windows host contains a library that is affected by a denial of service vulnerability.

Description

The version of Artifex Ghostscript installed on the remote Windows host is 9.22 or earlier. It is, therefore, affected by a denial of service vulnerability due to improperly handling PostScript data. A context-dependent attacker could cause a buffer overflow, potentially crashing the service.

Solution

Update to 9.23 or refer to bug 699255 for possible workarounds or patches.

See Also

https://seclists.org/oss-sec/2018/q2/58

https://bugs.ghostscript.com/show_bug.cgi?id=699255

http://www.nessus.org/u?d3f6a0f5

Plugin Details

Severity: Medium

ID: 109405

File Name: ghostscript_9_23.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 2018/04/27

Updated: 2019/03/29

Dependencies: 100357

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-10194

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Patch Publication Date: 2018/04/18

Vulnerability Publication Date: 2018/04/18

Reference Information

CVE: CVE-2018-10194