CVE-2018-10194

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.

References

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=39b1e54b2968620723bf32e96764c88797714879

http://www.securitytracker.com/id/1040729

https://access.redhat.com/errata/RHSA-2018:2918

https://bugs.ghostscript.com/show_bug.cgi?id=699255

https://lists.debian.org/debian-lts-announce/2018/04/msg00028.html

https://security.gentoo.org/glsa/201811-12

https://usn.ubuntu.com/3636-1/

Details

Source: MITRE

Published: 2018-04-18

Updated: 2019-07-24

Type: CWE-119

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH

Tenable Plugins

View all (26 total)

IDNameProductFamilySeverity
127204NewStart CGSL CORE 5.04 / MAIN 5.04 : ghostscript Multiple Vulnerabilities (NS-SA-2019-0035)NessusNewStart CGSL Local Security Checks
high
125565EulerOS Virtualization for ARM 64 3.0.2.0 : ghostscript (EulerOS-SA-2019-1613)NessusHuawei Local Security Checks
high
123901EulerOS Virtualization 2.5.4 : ghostscript (EulerOS-SA-2019-1215)NessusHuawei Local Security Checks
high
123862EulerOS Virtualization 2.5.3 : ghostscript (EulerOS-SA-2019-1176)NessusHuawei Local Security Checks
high
123210openSUSE Security Update : ghostscript (openSUSE-2019-505)NessusSuSE Local Security Checks
high
122709EulerOS Virtualization 2.5.2 : ghostscript (EulerOS-SA-2019-1087)NessusHuawei Local Security Checks
high
120574Fedora 28 : ghostscript (2018-8359498f3c)NessusFedora Local Security Checks
high
120031SUSE SLED15 / SLES15 Security Update : ghostscript (SUSE-SU-2018:1884-1)NessusSuSE Local Security Checks
high
119919EulerOS 2.0 SP2 : ghostscript (EulerOS-SA-2018-1430)NessusHuawei Local Security Checks
high
119532EulerOS 2.0 SP3 : ghostscript (EulerOS-SA-2018-1404)NessusHuawei Local Security Checks
high
119132GLSA-201811-12 : GPL Ghostscript: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
119087Virtuozzo 7 : ghostscript / ghostscript-cups / ghostscript-devel / etc (VZLSA-2018-2918)NessusVirtuozzo Local Security Checks
high
118166Scientific Linux Security Update : ghostscript on SL7.x x86_64 (20181016)NessusScientific Linux Local Security Checks
high
118128RHEL 7 : ghostscript (RHSA-2018:2918)NessusRed Hat Local Security Checks
high
118125Oracle Linux 7 : ghostscript (ELSA-2018-2918)NessusOracle Linux Local Security Checks
high
118118CentOS 7 : ghostscript (CESA-2018:2918)NessusCentOS Local Security Checks
high
117372Fedora 27 : ghostscript (2018-28447b6f2e)NessusFedora Local Security Checks
high
110962openSUSE Security Update : ghostscript (openSUSE-2018-706)NessusSuSE Local Security Checks
high
110195Amazon Linux 2 : ghostscript (ALAS-2018-1022)NessusAmazon Linux Local Security Checks
high
110036SUSE SLES11 Security Update : ghostscript-library (SUSE-SU-2018:1369-1)NessusSuSE Local Security Checks
high
109937SUSE SLED12 / SLES12 Security Update : ghostscript (SUSE-SU-2018:1332-1)NessusSuSE Local Security Checks
high
109934openSUSE Security Update : ghostscript (openSUSE-2018-479)NessusSuSE Local Security Checks
high
109434Fedora 27 : ghostscript (2018-3247413570)NessusFedora Local Security Checks
high
109416Fedora 26 : ghostscript (2018-226dac231f)NessusFedora Local Security Checks
high
109405Artifex Ghostscript PostScript Handling Buffer Overflow DoSNessusWindows
high
109347Debian DLA-1363-1 : ghostscript security updateNessusDebian Local Security Checks
high