CKEditor 4.5.11 < 4.9.2 Enhanced Image Plugin XSS

Medium Nessus Plugin ID 109403

Synopsis

The remote web server hosts a script that is affected by a cross-site scripting vulnerability.

Description

The version of CKEditor installed on the remote host is affected by a cross-site scripting vulnerability.

The included 'Enhanced Image' plugin causes CKEditor to fail to properly sanitize user-supplied input. A remote, unauthenticated attacker can leverage this issue to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to version CKEditor 4.9.2 or later.

See Also

http://www.nessus.org/u?be1255cc

Plugin Details

Severity: Medium

ID: 109403

File Name: ckeditor_image2_xss.nasl

Version: 1.2

Type: remote

Published: 2018/04/27

Updated: 2018/08/09

Dependencies: 10107

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:ckeditor:ckeditor

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Patch Publication Date: 2018/04/17

Vulnerability Publication Date: 2018/04/17

Reference Information

CVE: CVE-2018-9861

BID: 103924

IAVA: 2018-A-0139