FreeBSD : drupal -- Drupal Core - Multiple Vulnerabilities (a9e466e8-4144-11e8-a292-00e04c1ea73d) (Drupalgeddon 2)

High Nessus Plugin ID 109055

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Drupal Security Team reports :

CVE-2018-7600: Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Solution

Update the affected package.

See Also

http://www.nessus.org/u?8ffa708c

Plugin Details

Severity: High

ID: 109055

File Name: freebsd_pkg_a9e466e8414411e8a29200e04c1ea73d.nasl

Version: 1.17

Type: local

Published: 2018/04/16

Updated: 2019/06/04

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:drupal7, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/04/16

Vulnerability Publication Date: 2018/03/13

Exploitable With

Core Impact

Metasploit (Drupal Drupalgeddon 2 Forms API Property Injection)

Elliot (Drupal 8 SA-CORE-2018-002 RCE)

Reference Information

CVE: CVE-2018-7600