pfSense < 2.4.3 Multiple Vulnerabilities (SA-18_01 / SA-18_02 / SA-18_03) (Meltdown) (Spectre)

High Nessus Plugin ID 109038


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is a version prior to 2.4.3 It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.


Upgrade to pfSense version 2.4.3 or later.

See Also

Plugin Details

Severity: High

ID: 109038

File Name: pfsense_SA-18_03.nasl

Version: 1.4

Type: remote

Family: Firewalls

Published: 2018/04/13

Updated: 2018/07/25

Dependencies: 106952

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/11/21

Vulnerability Publication Date: 2017/09/19

Reference Information

CVE: CVE-2017-5715, CVE-2017-5754, CVE-2018-6916

BID: 103513

FreeBSD: SA-18:01.ipsec, SA-18:03.speculative_execution

IAVA: 2018-A-0019, 2018-A-0020