Amazon Linux AMI : libvorbis (ALAS-2018-981)

Medium Nessus Plugin ID 108845

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Vorbis audio processing out of bounds write :

An out of bounds write flaw was found in the processing of vorbis audio data. A maliciously crafted file or audio stream could cause the application to crash or, potentially, execute arbitrary code.
(CVE-2018-5146)

Solution

Run 'yum update libvorbis' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2018-981.html

Plugin Details

Severity: Medium

ID: 108845

File Name: ala_ALAS-2018-981.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2018/04/06

Updated: 2018/08/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:libvorbis, p-cpe:/a:amazon:linux:libvorbis-debuginfo, p-cpe:/a:amazon:linux:libvorbis-devel, p-cpe:/a:amazon:linux:libvorbis-devel-docs, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2018/04/05

Reference Information

CVE: CVE-2018-5146

ALAS: 2018-981