Cisco IOS XE Software Smart Install Remote Code Execution Vulnerability

Critical Nessus Plugin ID 108723

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version, the IOS XE is affected by one or more vulnerabilities. Please see the included Cisco BIDs and the Cisco Security Advisory for more information.

Solution

Upgrade to the relevant fixed version referenced in Cisco bug ID(s) CSCvg76186.

See Also

http://www.nessus.org/u?09597efb

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvg76186

Plugin Details

Severity: Critical

ID: 108723

File Name: cisco-sa-20180328-smi2-iosxe.nasl

Version: 1.14

Type: local

Family: CISCO

Published: 2018/03/29

Updated: 2019/04/02

Dependencies: 67217

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2018-0171

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:cpe:/o:cisco:ios_xe

Required KB Items: Host/Cisco/IOS-XE/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/28

Reference Information

CVE: CVE-2018-0171

BID: 103538

CISCO-BUG-ID: CSCvg76186

CISCO-SA: cisco-sa-20180328-smi2

IAVA: 2018-A-0097