Mozilla Firefox < 59.0.1 Multiple Code Execution Vulnerabilities (macOS)

High Nessus Plugin ID 108585

Synopsis

A web browser installed on the remote macOS or Mac OS X host is affected by a multiple code execution vulnerabilities.

Description

The version of Mozilla Firefox installed on the remote macOS or Mac OS X host is prior to 59.0.1. It is, therefore, affected by multiple code execution vulnerabilities. A out-of-bounds write flaw exists in multiple functions of the codebook.c script when decoding Vorbis audio data. A context-dependent attacker could corrupt memory and potentially execute arbitrary code.

Solution

Upgrade to Mozilla Firefox version 59.0.1 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2018-08/

Plugin Details

Severity: High

ID: 108585

File Name: macos_firefox_59_0_1.nasl

Version: 1.4

Type: local

Agent: macosx

Published: 2018/03/23

Updated: 2019/11/08

Dependencies: 55417

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-5147

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: MacOSX/Firefox/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/03/16

Vulnerability Publication Date: 2018/03/15

Reference Information

CVE: CVE-2018-5146, CVE-2018-5147

BID: 103432

MFSA: 2018-08