Webmin < 1.860 Cross Site Scripting Vulnerability

medium Nessus Plugin ID 108561

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

According to its self-reported version, the Webmin install hosted on the remote host is prior to 1.860. It is, therefore, affected by a cross site scripting vulnerability.

Solution

Upgrade to Webmin 1.860 or later.

See Also

http://www.webmin.com/changes.html

Plugin Details

Severity: Medium

ID: 108561

File Name: webmin_1_860_xss.nasl

Version: 1.5

Type: remote

Published: 3/22/2018

Updated: 11/8/2019

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 10/10/2017

Vulnerability Publication Date: 10/10/2017

Reference Information

CVE: CVE-2017-15646