Webmin < 1.850 Multiple Cross Site Scripting Vulnerabilities

medium Nessus Plugin ID 108559
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple cross site scripting vulnerabilities.

Description

According to its self-reported version, the Webmin install hosted on the remote host is prior to 1.850. It is, therefore, affected by multiple cross site scripting vulnerabilities.

Solution

Upgrade to Webmin 1.850 or later.

See Also

https://www.securityfocus.com/bid/99373

http://www.webmin.com/changes.html

Plugin Details

Severity: Medium

ID: 108559

File Name: webmin_1_850.nasl

Version: 1.4

Type: remote

Published: 3/22/2018

Updated: 11/12/2019

Dependencies: webmin.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/28/2017

Vulnerability Publication Date: 6/28/2017

Reference Information

CVE: CVE-2017-9313

BID: 99373