Webmin < 1.760 xmlrpc.cgi Cross Site Scripting Vulnerability

High Nessus Plugin ID 108557

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

According to its self-reported version, the Webmin install hosted on the remote host is prior to 1.760. It is, therefore, affected by a cross site scripting vulnerability in xmlrpc.cgi, which could potentially lead to remote code execution in certain products.

Solution

Upgrade to Webmin 1.760 or later.

See Also

https://www.securityfocus.com/bid/76700

http://www-01.ibm.com/support/docview.wss?uid=swg21965817

http://www.webmin.com/changes-1.760.html

Plugin Details

Severity: High

ID: 108557

File Name: webmin_1_760.nasl

Version: 1.2

Type: remote

Published: 2018/03/22

Updated: 2018/11/15

Dependencies: 10757

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Patch Publication Date: 2015/06/22

Vulnerability Publication Date: 2015/06/22

Reference Information

CVE: CVE-2015-2011

BID: 76700