Webmin <= 1.540 Cross Site Scripting

Medium Nessus Plugin ID 108554

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

According to its self-reported version, the Webmin install hosted on the remote host is 1.540 or lower. It is, therefore, affected by a cross site scripting vulnerability via a chfn command.

Solution

Upgrade to Webmin 1.550 or later.

See Also

https://www.securityfocus.com/bid/47558

http://www.webmin.com/changes.html

Plugin Details

Severity: Medium

ID: 108554

File Name: webmin_1_550.nasl

Version: 1.3

Type: remote

Published: 2018/03/22

Updated: 2018/11/15

Dependencies: 10757

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/04/26

Vulnerability Publication Date: 2011/04/26

Reference Information

CVE: CVE-2011-1937

BID: 47558