Webmin < 1.350 pam_login.cgi Cross Site Scripting

medium Nessus Plugin ID 108551

Synopsis

The remote web server is affected by multiple cross site scripting vulnerabilities.

Description

According to its self-reported version, the Webmin install hosted on the remote host is prior to 1.350. It is, therefore, affected by a number of cross site scripting vulnerabilities in pam_login.cgi

Solution

Upgrade to Webmin 1.350 or later.

See Also

https://www.securityfocus.com/bid/24381

http://www.webmin.com/changes.html

Plugin Details

Severity: Medium

ID: 108551

File Name: webmin_1_350.nasl

Version: 1.5

Type: remote

Published: 3/22/2018

Updated: 11/15/2018

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 1.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.7

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 6/1/2007

Vulnerability Publication Date: 6/1/2007

Reference Information

CVE: CVE-2007-3156

BID: 24381

CWE: 79