Webmin < 1.350 pam_login.cgi Cross Site Scripting

medium Nessus Plugin ID 108551
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 2.4


The remote web server is affected by multiple cross site scripting vulnerabilities.


According to its self-reported version, the Webmin install hosted on the remote host is prior to 1.350. It is, therefore, affected by a number of cross site scripting vulnerabilities in pam_login.cgi


Upgrade to Webmin 1.350 or later.

See Also



Plugin Details

Severity: Medium

ID: 108551

File Name: webmin_1_350.nasl

Version: 1.5

Type: remote

Published: 3/22/2018

Updated: 11/15/2018

Dependencies: webmin.nasl

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

VPR Score: 2.4

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin, Settings/ParanoidReport

Exploit Ease: No exploit is required

Patch Publication Date: 6/1/2007

Vulnerability Publication Date: 6/1/2007

Reference Information

CVE: CVE-2007-3156

BID: 24381

CWE: 79