Webmin chooser.cgi Cross-Site Scripting (< 1.330)

Medium Nessus Plugin ID 108541


The remote web server is affected by a script injection vulnerability.


The version of Webmin installed on the remote host is older than 1.330. It is, therefore, affected by multiple cross-site scripting (XSS) vulnerabilities in chooser.cgi. These flaws allow remote attackers to inject arbitrary web script or HTML via a crafted filename. Note that Nessus has relied on the self-reported version of the sofware from either the index page or the Server header.


Upgrade to Webmin version 1.330 or later.

See Also


Plugin Details

Severity: Medium

ID: 108541

File Name: webmin_1330.nasl

Version: 1.2

Type: remote

Published: 2018/03/22

Updated: 2018/08/15

Dependencies: 10757

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:webmin:webmin

Required KB Items: www/webmin

Patch Publication Date: 2007/03/05

Vulnerability Publication Date: 2007/03/05

Reference Information

CVE: CVE-2007-1276