pfSense < 2.4.2 Multiple Vulnerabilities (SA-17_07)

Medium Nessus Plugin ID 108517

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.6

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is a version prior to 2.4.2 It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.

Solution

Upgrade to pfSense version 2.4.2 or later.

See Also

http://www.nessus.org/u?e1b23834

Plugin Details

Severity: Medium

ID: 108517

File Name: pfsense_SA-17_07.nasl

Version: 1.10

Type: remote

Family: Firewalls

Published: 2018/03/21

Updated: 2019/11/08

Dependencies: 106952

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS Score Source: CVE-2017-3735

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/21

Vulnerability Publication Date: 2017/09/19

Reference Information

CVE: CVE-2017-1086, CVE-2017-1088, CVE-2017-3735, CVE-2017-3736

BID: 103513

FreeBSD: SA-17:08.ptrace, SA-17:10.kldstat, SA-17:11.openssl