Debian DSA-4140-1 : libvorbis - security update

Medium Nessus Plugin ID 108417

Synopsis

The remote Debian host is missing a security-related update.

Description

Richard Zhu discovered that an out-of-bounds memory write in the codebook parsing code of the Libvorbis multimedia library could result in the execution of arbitrary code if a malformed Vorbis file is opened.

Solution

Upgrade the libvorbis packages.

For the oldstable distribution (jessie), this problem has been fixed in version 1.3.4-2+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 1.3.5-4+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893130

https://security-tracker.debian.org/tracker/source-package/libvorbis

https://packages.debian.org/source/jessie/libvorbis

https://packages.debian.org/source/stretch/libvorbis

https://www.debian.org/security/2018/dsa-4140

Plugin Details

Severity: Medium

ID: 108417

File Name: debian_DSA-4140.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2018/03/19

Updated: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libvorbis, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/03/16

Reference Information

CVE: CVE-2018-5146

DSA: 4140