openSUSE Security Update : postgresql94 (openSUSE-2018-257)

Low Nessus Plugin ID 108391

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for postgresql94 fixes the following issues :

PostgreSQL was updated to version 9.4.15, the full release notes are here :

	https://www.postgresql.org/docs/9.4/static/release-9-4-15.html

- CVE-2018-1053: Ensure that all temporary files made by pg_upgrade are non-world-readable. (bsc#1077983)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected postgresql94 packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1077983

https://www.postgresql.org/docs/9.4/release-9-4-15.html

Plugin Details

Severity: Low

ID: 108391

File Name: openSUSE-2018-257.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/03/16

Updated: 2018/12/18

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:N

CVSS v3.0

Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:postgresql94, p-cpe:/a:novell:opensuse:postgresql94-contrib, p-cpe:/a:novell:opensuse:postgresql94-contrib-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-debugsource, p-cpe:/a:novell:opensuse:postgresql94-devel, p-cpe:/a:novell:opensuse:postgresql94-devel-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-libs-debugsource, p-cpe:/a:novell:opensuse:postgresql94-plperl, p-cpe:/a:novell:opensuse:postgresql94-plperl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-plpython, p-cpe:/a:novell:opensuse:postgresql94-plpython-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-pltcl, p-cpe:/a:novell:opensuse:postgresql94-pltcl-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-server, p-cpe:/a:novell:opensuse:postgresql94-server-debuginfo, p-cpe:/a:novell:opensuse:postgresql94-test, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/03/15

Reference Information

CVE: CVE-2018-1053