nginx < 1.8.1 / 1.9.x < 1.9.10 Multiple Vulnerabilities

High Nessus Plugin ID 107265


The remote web server is affected by multiple vulnerabilities.


According to the self-reported version in its response header, the version of nginx hosted on the remote web server is less than 1.8.1 or 1.9.x prior to 1.9.10. It is, therefore, affected by multiple vulnerabilities as noted in the vendor advisory.


Upgrade to nginx version 1.8.1 / 1.9.10 or later.

See Also

Plugin Details

Severity: High

ID: 107265

File Name: nginx_1_8_1.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2018/03/09

Updated: 2019/11/08

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/01/26

Vulnerability Publication Date: 2016/01/26

Reference Information

CVE: CVE-2016-0742, CVE-2016-0746, CVE-2016-0747