openSUSE Security Update : wavpack (openSUSE-2018-227)

Medium Nessus Plugin ID 107182

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for wavpack fixes the following issues :

- CVE-2016-10169 CVE-2016-10170 CVE-2016-10171 CVE-2016-10172: Make sure upper and lower boundaries make sense, to avoid out of bounds memory reads that could lead to crashes or disclosing memory.
(bsc#1021483)

This update was imported from the SUSE:SLE-12:Update update project.

Solution

Update the affected wavpack packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1021483

Plugin Details

Severity: Medium

ID: 107182

File Name: openSUSE-2018-227.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/03/07

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSSv3

Base Score: 5.5

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libwavpack1, p-cpe:/a:novell:opensuse:libwavpack1-32bit, p-cpe:/a:novell:opensuse:libwavpack1-debuginfo, p-cpe:/a:novell:opensuse:libwavpack1-debuginfo-32bit, p-cpe:/a:novell:opensuse:wavpack, p-cpe:/a:novell:opensuse:wavpack-debuginfo, p-cpe:/a:novell:opensuse:wavpack-debugsource, p-cpe:/a:novell:opensuse:wavpack-devel, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/03/06

Reference Information

CVE: CVE-2016-10169, CVE-2016-10170, CVE-2016-10171, CVE-2016-10172