openSUSE Security Update : leptonica (openSUSE-2018-226)

High Nessus Plugin ID 107181

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for leptonica fixes the following issues :

- CVE-2018-7247: Fixed a buffer overflow in in src/viewfiles.c with unsanitized input (rootname) (boo#1081631)

- CVE-2018-7186: Fixed multiple stack-based buffer overflows in gplotRead() and ptaReadStream() (boo#1081576)

- CVE-2018-3836: Added additional bad characters, to prevent command injection by invoking it via $(command) (boo#1079358)

Solution

Update the affected leptonica packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1079358

https://bugzilla.opensuse.org/show_bug.cgi?id=1081576

https://bugzilla.opensuse.org/show_bug.cgi?id=1081631

Plugin Details

Severity: High

ID: 107181

File Name: openSUSE-2018-226.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/03/07

Modified: 2018/03/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:leptonica-debugsource, p-cpe:/a:novell:opensuse:leptonica-devel, p-cpe:/a:novell:opensuse:leptonica-tools, p-cpe:/a:novell:opensuse:leptonica-tools-debuginfo, p-cpe:/a:novell:opensuse:liblept4, p-cpe:/a:novell:opensuse:liblept4-32bit, p-cpe:/a:novell:opensuse:liblept4-debuginfo, p-cpe:/a:novell:opensuse:liblept4-debuginfo-32bit, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/03/06

Reference Information

CVE: CVE-2018-3836, CVE-2018-7186, CVE-2018-7247