openSUSE Security Update : freexl (openSUSE-2018-217)

Medium Nessus Plugin ID 107113


The remote openSUSE host is missing a security update.


This update for freexl fixes the following issues :

freexl was updated to version 1.0.5 :

- No changelog provided by upstream

- Various heapoverflows in 1.0.4 have been fixed :

- CVE-2018-7439: heap-buffer-overflow in freexl.c:3912 read_mini_biff_next_record (boo#1082774)

- CVE-2018-7438: heap-buffer-overflow in freexl.c:383 parse_unicode_string (boo#1082775)

- CVE-2018-7437: heap-buffer-overflow in freexl.c:1866 parse_SST(boo#1082776)

- CVE-2018-7436: heap-buffer-overflow in freexl.c:1805 parse_SST parse_SST (boo#1082777)

- CVE-2018-7435: heap-buffer-overflow in freexl::destroy_cell (boo#1082778)


Update the affected freexl packages.

See Also

Plugin Details

Severity: Medium

ID: 107113

File Name: openSUSE-2018-217.nasl

Version: $Revision: 3.2 $

Type: local

Agent: unix

Published: 2018/03/02

Modified: 2018/03/05

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P


Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:freexl-debugsource, p-cpe:/a:novell:opensuse:freexl-devel, p-cpe:/a:novell:opensuse:libfreexl1, p-cpe:/a:novell:opensuse:libfreexl1-debuginfo, cpe:/o:novell:opensuse:42.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2018/03/01

Reference Information

CVE: CVE-2018-7435, CVE-2018-7436, CVE-2018-7437, CVE-2018-7438, CVE-2018-7439