FreeBSD : cvs -- Remote code execution via ssh command injection (d9fe59ea-1940-11e8-9eb8-5404a68ad561)

Medium Nessus Plugin ID 106996

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Hank Leininger reports :

Bugs in Git, Subversion, and Mercurial were just announced and patched which allowed arbitrary local command execution if a malicious name was used for the remote server, such as starting with - to pass options to the ssh client : git clone ssh://-oProxyCommand=some-command... CVS has a similar problem with the -d option :

Tested vanilla CVS 1.12.13, and Gentoo CVS 1.12.12-r11.

Solution

Update the affected package.

See Also

http://lists.nongnu.org/archive/html/bug-cvs/2017-08/msg00000.html

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871810#10

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226088

http://www.nessus.org/u?dd77a67a

Plugin Details

Severity: Medium

ID: 106996

File Name: freebsd_pkg_d9fe59ea194011e89eb85404a68ad561.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2018/02/26

Modified: 2018/02/26

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:cvs, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/24

Vulnerability Publication Date: 2017/08/10

Reference Information

CVE: CVE-2017-12836