FreeBSD : drupal -- Drupal Core - Multiple Vulnerabilities (57580fcc-1a61-11e8-97e0-00e04c1ea73d)

High Nessus Plugin ID 106994


The remote FreeBSD host is missing one or more security-related updates.


Drupal Security Team reports :

CVE-2017-6926: Comment reply form allows access to restricted content

CVE-2017-6927: JavaScript cross-site scripting prevention is incomplete

CVE-2017-6928: Private file access bypass - Moderately Critical

CVE-2017-6929: jQuery vulnerability with untrusted domains - Moderately Critical

CVE-2017-6930: Language fallback can be incorrect on multilingual sites with node access restrictions

CVE-2017-6931: Settings Tray access bypass

CVE-2017-6932: External link injection on 404 pages when linking to the current page


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 106994

File Name: freebsd_pkg_57580fcc1a6111e897e000e04c1ea73d.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2018/02/26

Modified: 2018/03/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:drupal7, p-cpe:/a:freebsd:freebsd:drupal8, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/25

Vulnerability Publication Date: 2018/02/21

Reference Information

CVE: CVE-2017-6926, CVE-2017-6927, CVE-2017-6928, CVE-2017-6929, CVE-2017-6930, CVE-2017-6931, CVE-2017-6932

IAVA: 2018-A-0063