FreeBSD : asterisk -- multiple vulnerabilities (933654ce-17b8-11e8-90b8-001999f8d30b)

High Nessus Plugin ID 106959


The remote FreeBSD host is missing a security-related update.


The Asterisk project reports :

AST-2018-004 - When processing a SUBSCRIBE request the res_pjsip_pubsub module stores the accepted formats present in the Accept headers of the request. This code did not limit the number of headers it processed despite having a fixed limit of 32. If more than 32 Accept headers were present the code would write outside of its memory and cause a crash.

AST-2018-005 - A crash occurs when a number of authenticated INVITE messages are sent over TCP or TLS and then the connection is suddenly closed. This issue leads to a segmentation fault.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 106959

File Name: freebsd_pkg_933654ce17b811e890b8001999f8d30b.nasl

Version: $Revision: 3.2 $

Type: local

Published: 2018/02/23

Modified: 2018/03/05

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:asterisk13, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/22

Vulnerability Publication Date: 2018/02/21

Reference Information

CVE: CVE-2018-7284, CVE-2018-7286

IAVA: 2018-A-0064