Atlassian Confluence < 6.6.1 viewdefaultdecorator Reflected XSS (CVE-2017-18085)

Medium Nessus Plugin ID 106949


A web application running on the remote host is affected by a reflected cross-site scripting vulnerability.


According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.6.1.
It is, therefore, affected by a reflected cross-site scripting vulnerability in the viewdefaultdecorator resource.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 6.6.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 106949

File Name: confluence_6_6_1.nasl

Version: 1.4

Type: remote

Published: 2018/02/22

Updated: 2019/04/26

Dependencies: 53574

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: www/confluence, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2018/01/08

Vulnerability Publication Date: 2018/02/02

Reference Information

CVE: CVE-2017-18085

BID: 103062