Atlassian Confluence < 6.3.4 usermacros Reflected XSS (CVE-2017-18084)

Low Nessus Plugin ID 106947

Synopsis

A web application running on the remote host is affected by a reflected cross-site scripting vulnerability.

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.3.4.
It is, therefore, affected by a reflected cross-site scripting vulnerability in the usermacros resource.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 6.3.4 or later.

See Also

https://jira.atlassian.com/browse/CONFSERVER-54904

Plugin Details

Severity: Low

ID: 106947

File Name: confluence_6_3_4.nasl

Version: 1.4

Type: remote

Published: 2018/02/22

Modified: 2018/07/09

Dependencies: 53574

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 3.5

Temporal Score: 3

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: www/confluence, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2017/09/05

Vulnerability Publication Date: 2018/02/02

Reference Information

CVE: CVE-2017-18084

BID: 103064

IAVA: 2018-A-0060