FreeBSD : libraw -- multiple DoS vulnerabilities (c60804f1-126f-11e8-8b5b-4ccc6adda413)

High Nessus Plugin ID 106858


The remote FreeBSD host is missing a security-related update.


Secunia Research reports :

CVE-2017-16909: An error related to the 'LibRaw::panasonic_load_raw()' function (dcraw_common.cpp) can be exploited to cause a heap-based buffer overflow and subsequently cause a crash via a specially crafted TIFF image.

CVE-2017-16910: An error within the 'LibRaw::xtrans_interpolate()' function (internal/dcraw_common.cpp) can be exploited to cause an invalid read memory access.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 106858

File Name: freebsd_pkg_c60804f1126f11e88b5b4ccc6adda413.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2018/02/16

Modified: 2018/02/16

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libraw, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/15

Vulnerability Publication Date: 2017/12/04

Reference Information

CVE: CVE-2017-16909, CVE-2017-16910