FreeBSD : bro -- out of bounds write allows remote DOS (746d04dc-507e-4450-911f-4c41e48bb07a)

High Nessus Plugin ID 106856

Synopsis

The remote FreeBSD host is missing a security-related update.

Description

Frank Meier :

Bro before Bro v2.5.2 is vulnerable to an out of bounds write in the ContentLine analyzer allowing remote attackers to cause a denial of service (crash) and possibly other exploitation.

Solution

Update the affected package.

See Also

http://www.nessus.org/u?496eb651

http://www.nessus.org/u?87c4c20e

Plugin Details

Severity: High

ID: 106856

File Name: freebsd_pkg_746d04dc507e4450911f4c41e48bb07a.nasl

Version: 3.3

Type: local

Published: 2018/02/16

Updated: 2018/12/19

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:bro, cpe:/o:freebsd:freebsd

Patch Publication Date: 2018/02/16

Vulnerability Publication Date: 2017/10/16