PostgreSQL 9.3.x < 9.3.21 / 9.4.x < 9.4.16 / 9.5.x < 9.5.11 / 9.6.x < 9.6.7 / 10.x < 10.2 Multiple Vulnerabilities

High Nessus Plugin ID 106842

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.3.x prior to 9.3.21, 9.4.x prior to 9.4.16, 9.5.x prior to 9.5.11, 9.6.x prior to 9.6.7, or 10.x prior to 10.2. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to PostgreSQL version 9.3.21 / 9.4.16 / 9.5.11 / 9.6.7 / 10.2 or later.

See Also

https://www.postgresql.org/about/news/1829/

https://www.postgresql.org/docs/current/static/release-9-3-21.html

https://www.postgresql.org/docs/current/static/release-9-4-16.html

https://www.postgresql.org/docs/current/static/release-9-5-11.html

https://www.postgresql.org/docs/current/static/release-9-6-7.html

https://www.postgresql.org/docs/current/static/release-10-2.html

Plugin Details

Severity: High

ID: 106842

File Name: postgresql_20180208.nasl

Version: 1.8

Type: local

Family: Databases

Published: 2018/02/15

Modified: 2018/09/17

Dependencies: 63346

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-1052

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/02/05

Vulnerability Publication Date: 2018/02/05

Reference Information

CVE: CVE-2018-1052, CVE-2018-1053

BID: 102987, 102986