FreeBSD : exim -- a buffer overflow vulnerability, remote code execution (316b3c3e-0e98-11e8-8d41-97657151f8c2)

High Nessus Plugin ID 106733


The remote FreeBSD host is missing a security-related update.


Exim developers report :

There is a buffer overflow in base64d(), if some pre-conditions are met. Using a handcrafted message, remote code execution seems to be possible.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 106733

File Name: freebsd_pkg_316b3c3e0e9811e88d4197657151f8c2.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2018/02/12

Modified: 2018/02/12

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:exim, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/10

Vulnerability Publication Date: 2018/02/05