FreeBSD : PostgreSQL vulnerabilities (c602c791-0cf4-11e8-a2ec-6cc21735f730)

Medium Nessus Plugin ID 106701

Synopsis

The remote FreeBSD host is missing one or more security-related updates.

Description

The PostgreSQL project reports :

- CVE-2018-1052: Fix the processing of partition keys containing multiple expressions (only for PostgreSQL-10.x)

- CVE-2018-1053: Ensure that all temporary files made with 'pg_upgrade' are non-world-readable

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?50953fe6

Plugin Details

Severity: Medium

ID: 106701

File Name: freebsd_pkg_c602c7910cf411e8a2ec6cc21735f730.nasl

Version: 3.2

Type: local

Published: 2018/02/09

Modified: 2018/03/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSSv3

Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:postgresql10-server, p-cpe:/a:freebsd:freebsd:postgresql93-server, p-cpe:/a:freebsd:freebsd:postgresql94-server, p-cpe:/a:freebsd:freebsd:postgresql95-server, p-cpe:/a:freebsd:freebsd:postgresql96-server, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2018/02/08

Vulnerability Publication Date: 2018/02/05

Reference Information

CVE: CVE-2018-1052, CVE-2018-1053