JQuery 1.x < 1.12.0 / 2.x < 2.2.0 XSS

Medium Nessus Plugin ID 106657


The remote web server is affected by a cross site scripting vulnerability.


According to the self-reported version in the script, the version of JQuery hosted on the remote web server is 1.x prior to 1.12.0 or 2.x prior to 2.2.0. It is, therefore, affected by a cross site scripting vulnerability when using location.host to select elements.


Upgrade to JQuery version 1.12.0 or later.

See Also


Plugin Details

Severity: Medium

ID: 106657

File Name: jquery_2_2_0.nasl

Version: $Revision: 1.2 $

Type: remote

Published: 2018/02/07

Modified: 2018/02/08

Dependencies: 106658

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/09/10

Vulnerability Publication Date: 2015/06/15

Reference Information

CVE: CVE-2015-9251

OSVDB: 132727