JQuery 1.x < 1.12.0 / 2.x < 2.2.0 XSS

Medium Nessus Plugin ID 106657


The remote web server is affected by a cross site scripting vulnerability.


The version of JQuery library hosted on the remote web server is 1.x prior to 1.12.0 or 2.x prior to 2.2.0. It is, therefore, affected by a cross site scripting vulnerability when using location.host to select elements.


Upgrade to JQuery version 1.12.0 or later.

See Also


Plugin Details

Severity: Medium

ID: 106657

File Name: jquery_2_2_0.nasl

Version: 1.5

Type: remote

Published: 2018/02/07

Updated: 2019/05/15

Dependencies: 106658

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2015/09/10

Vulnerability Publication Date: 2015/06/15