JQuery 1.6.x < 1.6.3 XSS

Medium Nessus Plugin ID 106656

Synopsis

The remote web server is affected by a cross site scripting vulnerability.

Description

According to the self-reported version in the script, the version of JQuery hosted on the remote web server is 1.6.x prior to 1.6.3. It is, therefore, affected by a cross site scripting vulnerability when using location.host to select elements.

Solution

Upgrade to JQuery version 1.6.3 or later.

See Also

https://blog.jquery.com/2011/09/01/jquery-1-6-3-released/

Plugin Details

Severity: Medium

ID: 106656

File Name: jquery_1_6_3.nasl

Version: 1.3

Type: remote

Published: 2018/02/07

Modified: 2018/11/28

Dependencies: 106658

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport, installed_sw/jquery

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/09/01

Vulnerability Publication Date: 2011/09/01

Reference Information

CVE: CVE-2011-4969

BID: 58458