pfSense 2.3.x < 2.3.5-p1 / 2.4.x < 2.4.2-p1 Multiple Vulnerabilities (SA-17_10 / SA-17_11)

High Nessus Plugin ID 106507


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is a version 2.3.x prior to 2.3.5-p1 or 2.4.x prior to 2.4.2-p1. It is, therefore, affected by multiple vulnerabilities.


Upgrade to pfSense version 2.3.5-p1 / 2.4.2-p1 or later.

See Also

Plugin Details

Severity: High

ID: 106507

File Name: pfsense_SA-17_11.nasl

Version: $Revision: 1.3 $

Type: remote

Family: CGI abuses

Published: 2018/01/31

Modified: 2018/02/22

Dependencies: 106952

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 9.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/04

Vulnerability Publication Date: 2017/12/04

Reference Information

OSVDB: 171044, 171045, 171047