pfSense 2.3.x < 2.3.5-p1 / 2.4.x < 2.4.2-p1 Multiple Vulnerabilities (SA-17_10 / SA-17_11)

High Nessus Plugin ID 106507


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is a version 2.3.x prior to 2.3.5-p1 or 2.4.x prior to 2.4.2-p1. It is, therefore, affected by multiple vulnerabilities.


Upgrade to pfSense version 2.3.5-p1 / 2.4.2-p1 or later.

See Also

Plugin Details

Severity: High

ID: 106507

File Name: pfsense_SA-17_11.nasl

Version: 1.7

Type: remote

Family: Firewalls

Published: 2018/01/31

Updated: 2018/08/24

Dependencies: 106952

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.9

Temporal Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/12/04

Vulnerability Publication Date: 2017/12/04

Reference Information

CVE: CVE-2017-3737, CVE-2017-3738

BID: 103513