pfSense 2.3.x < 2.3.5 / 2.4.x < 2.4.2 Multiple XSS Vulnerabilites (SA-17_08 / SA-17_09)

Medium Nessus Plugin ID 106506

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is 2.3.x prior to 2.3.5 or 2.4.x prior to 2.4.2. It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.

Note: SA-17_09 only applies to 2.4.x.

Solution

Upgrade to pfSense version 2.3.5 / 2.4.2 or later.

See Also

http://www.nessus.org/u?424391cb

http://www.nessus.org/u?98d3ae56

Plugin Details

Severity: Medium

ID: 106506

File Name: pfsense_SA-17_09.nasl

Version: $Revision: 1.4 $

Type: remote

Published: 2018/01/31

Modified: 2018/02/22

Dependencies: 106952

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

CVSSv3

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/10/31

Vulnerability Publication Date: 2017/11/14

Reference Information

CVE: CVE-2017-1000479