pfSense 2.3.x < 2.3.5 / 2.4.x < 2.4.2 Multiple XSS Vulnerabilites (SA-17_08 / SA-17_09)

medium Nessus Plugin ID 106506
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 7.4


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is 2.3.x prior to 2.3.5 or 2.4.x prior to 2.4.2. It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.

Note: SA-17_09 only applies to 2.4.x.


Upgrade to pfSense version 2.3.5 / 2.4.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 106506

File Name: pfsense_SA-17_09.nasl

Version: 1.7

Type: remote

Published: 1/31/2018

Updated: 7/25/2018

Dependencies: pfsense_detect.nbin

Risk Information

Risk Factor: Medium

VPR Score: 7.4

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.9

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Ease: No exploit is required

Patch Publication Date: 10/31/2017

Vulnerability Publication Date: 11/14/2017

Exploitable With

Metasploit (Clickjacking Vulnerability In CSRF Error Page pfSense)

Reference Information

CVE: CVE-2017-1000479