pfSense < 2.3.4 DHCP Lease Display XSS (SA-17_04)

Medium Nessus Plugin ID 106504


The remote firewall host is affected by a cross-site scripting vulnerability.


According to its self-reported version number, the remote pfSense install is prior to 2.3.4. It is, therefore, affected by a cross-site scripting vulnerability (XSS) as stated in the referenced vendor advisory.


Upgrade to pfSense version 2.3.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 106504

File Name: pfsense_SA-17_04.nasl

Version: $Revision: 1.3 $

Type: remote

Published: 2018/01/31

Modified: 2018/02/22

Dependencies: 106952

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2017/04/26

Vulnerability Publication Date: 2017/04/26

Reference Information

OSVDB: 157174