pfSense < 2.3.3 Multiple Vulnerabilities (SA-17_01 - SA-17_03)

critical Nessus Plugin ID 106503


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is affected by multiple vulnerabilities as stated in the referenced vendor advisories.


Upgrade to pfSense version 2.3.3 or later.

See Also

Plugin Details

Severity: Critical

ID: 106503

File Name: pfsense_SA-17_03.nasl

Version: 1.12

Type: remote

Family: Firewalls

Published: 1/31/2018

Updated: 11/8/2019

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2016-6559


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/17/2017

Vulnerability Publication Date: 2/17/2017

Reference Information

CVE: CVE-2016-1889, CVE-2016-6559, CVE-2016-7426, CVE-2016-7427, CVE-2016-7428, CVE-2016-7429, CVE-2016-7431, CVE-2016-7433, CVE-2016-7434, CVE-2016-8610, CVE-2016-8858, CVE-2016-9310, CVE-2016-9311, CVE-2016-9312, CVE-2016-10009, CVE-2016-10010

BID: 93776, 93841, 94444, 94446, 94447, 94448, 94450, 94451, 94452, 94453, 94454, 94455, 94694, 94968, 94972

CERT: 633847

FreeBSD: SA-16:29.bspatch, SA-16:31.libarchive, SA-16:33.openssh, SA-16:35.openssl, SA-16:37.libc, SA-16:38.bhyve, SA-16:39.ntp, SA-17:01.openssh