pfSense < 2.3.1 Multiple Vulnerabilities (SA-16_03 / SA-16-04)

High Nessus Plugin ID 106500


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is prior to 2.3.1. It is, therefore, affected by multiple vulnerabilities.


Upgrade to pfSense version 2.3.1 or later.

See Also

Plugin Details

Severity: High

ID: 106500

File Name: pfsense_SA-16_04.nasl

Version: 1.10

Type: remote

Family: Firewalls

Published: 2018/01/31

Updated: 2019/11/08

Dependencies: 106952

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-1887

CVSS Score Rationale: Defer to highest non-dos nvd score (cve-2016-1886)

CVSS v2.0

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2016/05/09

Vulnerability Publication Date: 2016/05/09

Exploitable With

Core Impact

Reference Information

CVE: CVE-2016-1886, CVE-2016-1887, CVE-2016-2105, CVE-2016-2106, CVE-2016-2107, CVE-2016-2109, CVE-2016-2176

BID: 87940, 89744, 89746, 89757, 89760, 90734

EDB-ID: 39768, 44212

FreeBSD: SA-16:17.openssl, SA-16:18.atkbd, SA-16:19.sendmsg