pfSense < 2.2 Multiple XSS Vulnerabilities (SA-15_01)

medium Nessus Plugin ID 106492


The remote firewall host is affected by multiple vulnerabilities.


According to its self-reported version number, the remote pfSense install is prior to 2.2. It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.


Upgrade to pfSense version 2.2 or later.

See Also

Plugin Details

Severity: Medium

ID: 106492

File Name: pfsense_SA-15_01.nasl

Version: Revision: 1.2

Type: remote

Published: 1/31/2018

Updated: 2/22/2018

Dependencies: pfsense_detect.nbin

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:pfsense:pfsense:*:*:*:*:*:*:*:*, cpe:2.3:a:bsdperimeter:pfsense:*:*:*:*:*:*:*:*

Required KB Items: Host/pfSense

Patch Publication Date: 1/23/2015

Vulnerability Publication Date: 1/23/2015