MySQL < 3.23.36 Multiple Vulnerabilities

high Nessus Plugin ID 10626


The remote database server is affected by multiple vulnerabilities.


The installed version of MySQL is older than version 3.23.36. Such versions are potentially affected by multiple vulnerabilities :

- It is possible to modify arbitrary files and gain privileges by creating a database with '..' characters.

- Users with a MySQL account can use the 'SHOW GRANTS' command to obtain the encrypted administrator password from the 'mysql.user' table. (CVE-2001-1275)

- Local users can modify passwords for arbitrary MySQL users via the 'GRANT' privilege. (CVE-2000-0045)


Upgrade to MySQL version 3.23.36 or later as this reportedly fixes the issue.

See Also

Plugin Details

Severity: High

ID: 10626

File Name: mysql_flaws.nasl

Version: 1.37

Type: remote

Family: Databases

Published: 3/8/2001

Updated: 11/15/2018

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 1/11/2000

Reference Information

CVE: CVE-2000-0045, CVE-2001-0407, CVE-2001-1275

BID: 2380, 2522, 926