PowerDNS Recursor < 4.0.7 API Configuration Injection Vulnerability (CVE-2017-15093)

Medium Nessus Plugin ID 106194


The remote name server is affected by a configuration injection vulnerability.


According to its self-reported version number, the version of the PowerDNS Recursor listening on the remote host is prior to to 4.0.7.
It is, therefore, affected by a vulnerability where a remote authenticated user can injection additional configuration directives via the API.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
Also, Nessus has not checked for the presence of the patch.


Upgrade to PowerDNS Recursor 4.0.7 or later. Alternatively, apply the patches referenced in the vendor advisories.

See Also




Plugin Details

Severity: Medium

ID: 106194

File Name: powerdns_recursor_4_0_7_2017-06.nasl

Version: $Revision: 1.2 $

Type: remote

Family: DNS

Published: 2018/01/19

Modified: 2018/01/22

Dependencies: 34043

Risk Information

Risk Factor: Medium


Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:/a:powerdns:powerdns, cpe:/a:powerdns:recursor

Required KB Items: pdns/version_full, pdns/version_source, pdns/type, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/27

Vulnerability Publication Date: 2017/11/27

Reference Information

CVE: CVE-2017-15093

BID: 101982

OSVDB: 169917