PowerDNS Recursor 4.0.x < 4.0.7 Multiple Vulnerabilities

Medium Nessus Plugin ID 106193


The remote name server is affected by multiple vulnerabilities.


According to its self-reported version number, the version of the PowerDNS Recursor listening on the remote host is version 4.0.x prior to 4.0.7. It is, therefore, affected by multiple vulnerabilities:

- Insufficient validation of DNSSEC signatures.

- Cross-Site Scripting (XSS) in the web interface.

- Memory leak in DNSSEC parsing. (CVE-2017-15094)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
Also, Nessus has not checked for the presence of the patch.


Upgrade to PowerDNS Recursor 4.0.7 or later. Alternatively, apply the patches referenced in the vendor advisories.

See Also






Plugin Details

Severity: Medium

ID: 106193

File Name: powerdns_recursor_4_0_7.nasl

Version: $Revision: 1.3 $

Type: remote

Family: DNS

Published: 2018/01/19

Modified: 2018/02/20

Dependencies: 34043

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:powerdns:powerdns, cpe:/a:powerdns:recursor

Required KB Items: pdns/version_full, pdns/version_source, pdns/type, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/27

Vulnerability Publication Date: 2017/11/27

Reference Information

CVE: CVE-2017-15090, CVE-2017-15092, CVE-2017-15094

BID: 101982

OSVDB: 169915, 169919, 169916