PowerDNS Authoritative < 4.0.5 Read Only Configuration Bypass (CVE-2017-15091)

Medium Nessus Plugin ID 106192

Synopsis

The remote name server is affected by a configuration bypass vulnerability.

Description

According to its self-reported version number, the version of the PowerDNS Authoritative listening on the remote host is prior to 4.0.5. It is, therefore, affected by a vulnerability in the API where a remote authenticated attacker can perform operations that affect the server state even if the api-readonly configuration is enabled.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.
Also, Nessus has not checked for the presence of the patch.

Solution

Upgrade to PowerDNS Authoritative 4.0.5 or later. Alternatively, apply the patches referenced in the vendor advisories.

See Also

http://www.nessus.org/u?d6d93a15

http://www.nessus.org/u?9ad28007

https://seclists.org/oss-sec/2017/q4/329

Plugin Details

Severity: Medium

ID: 106192

File Name: powerdns_authoritative_4_0_5.nasl

Version: 1.4

Type: remote

Family: DNS

Published: 2018/01/19

Modified: 2018/11/15

Dependencies: 34043

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:powerdns:powerdns, cpe:/a:powerdns:authoritative

Required KB Items: pdns/version_full, pdns/version_source, pdns/type, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/11/27

Vulnerability Publication Date: 2017/11/27

Reference Information

CVE: CVE-2017-15091

BID: 101982